Part Number
    Please enter a valid full or partial manufacturer part number with a minimum of 3 letters or numbers

    RFC 894 Search Results

    SF Impression Pixel

    RFC 894 Price and Stock

    ABB Low Voltage Products and Systems

    ABB Low Voltage Products and Systems RFC 500-6

    Terminals CU CRAB CONN ROLLBK INS COMP 500 6
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Mouser Electronics RFC 500-6
    • 1 $1597.67
    • 10 $1597.67
    • 100 $1597.67
    • 1000 $1597.67
    • 10000 $1597.67
    Get Quote

    ABB Low Voltage Products and Systems RFC 500-12

    Terminals CU CRAB CONN ROLLBK INS COMP 500 12
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Mouser Electronics RFC 500-12
    • 1 -
    • 10 $3376.76
    • 100 $3376.76
    • 1000 $3376.76
    • 10000 $3376.76
    Get Quote

    ABB Low Voltage Products and Systems RFC 500-16

    Terminals CU CRAB CONN ROLLBK INS COMP 500 16
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Mouser Electronics RFC 500-16
    • 1 -
    • 10 $3486.52
    • 100 $3486.52
    • 1000 $3486.52
    • 10000 $3486.52
    Get Quote

    ABB Low Voltage Products and Systems RFC 500-8

    Terminals CU CRAB CONN ROLLBK INS COMP 500 8
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Mouser Electronics RFC 500-8
    • 1 -
    • 10 $2253.02
    • 100 $2253.02
    • 1000 $2253.02
    • 10000 $2253.02
    Get Quote

    RFC 894 Datasheets Context Search

    Catalog Datasheet Type Document Tags PDF

    Contextual Info: F-205-1 RF CABLE ASSEMBLIES SERIES4’ RFC 316 SPECIFICATIONS For complete specifications see www.samtec.com?RFC-174 or www.samtec.com?RFC-316 RF Connector: Shell Material: Brass Contact Material: Brass Operating Temperature: -65°C to +165°C Voltage Rating: 170V max


    OCR Scan
    f-205-1rfc-174rfc-316024pf/foot PDF

    Contextual Info: F-205-1 MICRO RF CABLE ASSEMBLY SKS SPEC IFIC A TIO N S For complete specifications www.samtec.com? RFC-081 or www.samtec.com?RFC-113 Shell Material: Brass Contact Material: Brass Operating Temperature: -65°C to +165°C Voltage Rating: 170V max Dielectric Withstanding


    OCR Scan
    f-205-1rfc-081rfc-113152mm+180-fax PDF

    Contextual Info: F-205-1 RF CABLE ASSEMBLIES RFC-178 SERIES SPEC IFIC A TIO N S For complete specifications www.samtec.com?RFC-178 RF Connector: Shell Material: Brass Contact Material: Brass Operating Temperature: -65°C to +165°C Voltage Rating: 170V max Dielectric Withstanding


    OCR Scan
    f-205-1rfc-178432pf/foot PDF

    Contextual Info: MICROWAVE CORPORATION HMC446 v00.0802 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446 PDF

    Contextual Info: MICROWAVE CORPORATION HMC446 v00.0802 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446 PDF

    Contextual Info: MICROWAVE CORPORATION HMC446 v00.0802 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446 PDF

    hmc446tr

    Abstract: 0402CS 0603CS HMC446 mobile phone signal booster
    Contextual Info: MICROWAVE CORPORATION HMC446 v02.0304 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446hmc446tr0402cs0603cs+1mobile phone signal booster PDF

    Contextual Info: HMC446 / 446E v03.0805 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 / HMC446E is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446hmc446e PDF

    0402CS

    Abstract: 0603CS 446E HMC446
    Contextual Info: HMC446 / 446E v03.0805 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 / HMC446E is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446hmc446e0402cs0603cs+1446e PDF

    Contextual Info: HMC446 / 446E v03.0805 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 / HMC446E is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446hmc446e PDF

    HMC446E

    Abstract: 0402CS 0603CS 446E HMC446
    Contextual Info: HMC446 / 446E v03.0805 GaAs MMIC 10W T/R SWITCH, 824 - 894 MHz* Typical Applications Features The HMC446 / HMC446E is ideal for: Low Insertion Loss: 0.6 dB • ISM/Cellular Portables/Handsets High IIP3: +65 dBm • Automotive Telematic Applications High Input P0.1 dB: +40 dBm Tx


    Original
    hmc446hmc446e0402cs0603cs+1446e PDF

    Contextual Info: Datasheet | Switches RAPIER 48w SWITCH WAN Capable Layer 3 Fast Ethernet Switch AT-RP48w 48 x 10/100BASE-T ports 2 x SFP ports 1 x NSM bay supporting up to 4 PICs Performance Allied Telesis' Rapier 48w Layer 3 10/100Mbps switch delivers an unprecedented level of


    Original
    -rp48w10/100base-t10/100mbpslayer32+2115kbpsar021s PDF

    TIA-1057

    Abstract: fastpath router FASTPATH-TR069-PRIVATE-MIB gvrp IEEE8021-CFM-MIB bridge 3417 Broadcom switch cli ANSI/TIA1057 STP 2740 TR-069
    Contextual Info: FASTPATH Software Optional Floating Graphic can go here Broadcom’s FASTPATH® production-ready networking software helps manufacturers achieve record-setting time-to-market pe r f o rm a n c e fo r i n tr o d uc i n g ne w E t h e rn e t products. In part, this advantage comes from the


    Original
    48-portfastpath-sb306-rtia-1057fastpath router+8fastpath-tr069-private-mibgvrpieee8021-cfm-mibbridge 3417broadcom switch cliansi/tia1057stp 2740tr-069 PDF

    Contextual Info: Datasheet | Routers AT-AR410 SERIES Modular Branch Office Routers AT-AR410 Modular Branch Office Router AT-AR410S Secure Modular Branch Office Router Wirespeed E1/T1 IPsec VPN Operation With full Layer 3 multi-protocol routing combined with wirespeed VLAN switching in one


    Original
    -ar410-ar410sat-ar410at-ar024+2rs232115kbps PDF

    Contextual Info: Datasheet | Switches AT-8700XL SERIES Advanced Layer 2 - 4 Access Switches AT-8724XL 24 x 10/100 Layer 2 - Layer 4 with essential Layer 3 functionality and 2 Uplink Bays AT-8748XL 48 x 10/100 Layer 2 - Layer 4 with essential Layer 3 functionality and 2 Uplink Bays


    Original
    -8700xl-8724xl-8748xlat-8724xl+3at-8748xlat-8700xlat-a42 PDF

    Contextual Info: Datasheet | Switches AT-8600 SERIES Layer 3 Fast Ethernet Switches AT-8624T/2M 24 x 10/100BASE-T ports 2 x Uplink Module Bays AT-8624T/2M-V2 24 x 10/100BASE-T ports 2 x Uplink Module Bays pre-populated with AT-A65 modules 10/100/1000Base-T / 1000Base-X SFP Combo


    Original
    -8624t/2m10/100base-t-8624t/2m-v2at-a65+310/100/1000base-t1000base-x-8648t/2sp PDF

    Contextual Info: Data sheet HP 10500/7500 20G Unified Wired-WLAN Module Key features • Enterprise-scale capacity, performance, and high reliability for wireless networks • System-wide approach to WLAN reliability through Wi-Fi Clear Connect • Flexible forwarding modes


    Original
    11ac-ready11a/b/n4aa4-6468enw PDF

    Contextual Info: Datasheet | Routers AT-AR725 Modular Enterprise Router AT-AR725 2 x 10/100TX ports 2 x Asynchronous ports 2 x PIC card 128MB SDRAM upgradeable to 512MB 16MB Flash on Board Support up to 192MB Compact Flash High-Performance Routers Designed for medium to large businesses that


    Original
    -ar72510/100tx128mb512mb+3192mbat-ar700ar021s PDF

    TAG 8648

    Contextual Info: Datasheet | Routers AT-AR415S Secure Modular Router AT-AR415S 1 x 10/100BASE-T WAN port 4 x 10/100BASE-T LAN ports 1 x asynchronous port 1 x PIC bay Integrated Security Engine The AT-AR415S is a secure modular router offering performance, flexibility and security for


    Original
    -ar415s10/100base-tat-ar415s10/100mbps+1tag 8648 PDF

    Contextual Info: Datasheet | Switches RAPIER G6 SERIES Managed Layer 3 Gigabit Ethernet Switches AT-RPG6-xx 6 port 100/1000T Layer 3 switch 2 x Gigabit uplink bays AT-RPG6FSX/SC-xx 6 port 1000SX SC Layer 3 switch 2 x Gigabit uplink bays AT-RPG6FSX/MT-xx 6 port 1000SX (MT-RJ) Layer 3 switch


    Original
    100/1000t1000sx35gbpsat-g8lx10 PDF

    Contextual Info: Datasheet | Routers AT-AR750S-DP Secure VPN Router AT-AR750S-DP 2 x WAN 10/100Base-T ports 5 x LAN 10/100Base-T ports 2 x PICs 1 x Asynchronous console / Modem port Dual hot-swappable AC or DC redundant power supplies Secure Modular Routing Solution Designed with the needs of medium


    Original
    -ar750s-dp10/100base-tat-ar750s-dpar021s PDF

    Contextual Info: Datasheet | Routers AT-AR442S Secure SHDSL Router AT-AR442S 1 x SHDSL port 2 Wire & 4 Wire 5 x 10/100BASE-T ports 1 x PIC slot 1 x Asynchronous port Secure SHDSL Routing Solution The AT-AR442S secure SHDSL router provides business class quality and extensive software


    Original
    -ar442s10/100base-tat-ar442s PDF

    TAG 8648

    Contextual Info: Datasheet | Routers AT-AR440S Secure ADSL2+ Router AT-AR440S 1 5 1 1 x ADSL2+ port x 10/100BASE-T ports x PIC x Asynchronous port ADSL Business Class Routing Solution The AT-AR440S is a competitively priced, business-class, secure ADSL router.This desktop,


    Original
    -ar440s10/100base-tat-ar440sat-ar021s+1tag 8648 PDF

    Contextual Info: Datasheet | Routers AT-AR441S Secure ADSL2+ Router AT-AR441S 1 x ADSL2+ port 5 x 10/100Base-T ports 1 x PIC 1 x Asynchronous port ADSL Business Class Routing Solution The AT-AR441S is a competitively priced, business-class, secure ADSL router.This desktop,


    Original
    -ar441s10/100base-tat-ar441s PDF