Part Number
    Please enter a valid full or partial manufacturer part number with a minimum of 3 letters or numbers

    RFC 33 Search Results

    SF Impression Pixel

    RFC 33 Price and Stock

    Select Manufacturer

    IMO Precision Controls Ltd RFC3-3S

    Filter, 1 Phase, 3A, 230V; |Imo Precision Controls RFC3-3S
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Newark RFC3-3S Bulk 1
    • 1 $17.97
    • 10 $15.92
    • 100 $12.95
    • 1000 $11.94
    • 10000 $11.94
    Buy Now

    RF Connectors/RF Industries, Ltd (RFI) RFC-3355-4

    CABLE ASSY, BNC F BULKHEAD TO MCX R/A, 4 "
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Quest Components RFC-3355-4 2
    • 1 $15.00
    • 10 $15.00
    • 100 $15.00
    • 1000 $15.00
    • 10000 $15.00
    Buy Now

    RFC 33 Datasheets Context Search

    Catalog Datasheet Type Document Tags PDF

    RWF Series

    Abstract: IEC 60384-4 Marking d635
    Contextual Info: LARGE SIZED ALUMINUM ELECTROLYTIC CAPACITORS RFC RWF Series �85℃ 5,000Hrs assured. �Non-solvent proof. �High ripple capability. �Long life. �For UPS, Industrial Inverter �RoHS compliant. �Halogen-free capacitors are also available. RFC RWA


    Original
    000hrs120hz25max000vac+4arms/85rwf seriesiec 60384-4marking d635 PDF

    Contextual Info: SN74ALS6300 INPUT-SELECTABLE REFRESH TIMER 03311, DECEMBER 1989-HEVISED JULY 1990 Supports 16 Most Popular Microprocessor Speeds Supports Distributive- and Hldden-Refresh Operations ] RFC Polarity Options Available for RFC, REFREQ, and MREF Signals ] RST ] REFREQ


    OCR Scan
    sn74als63001989-hevisedals6300 PDF

    Contextual Info: RF CONNECTORS RFC SERIES Introduction: Adam Tech’s RFC series RF connectors are a comprehensive assortment of Radio Frequency signal connectors in standard, miniature, sub-miniature, micro miniature and surface mount styles. Included are BNC, TNC, FME, FMA, SMA, SMB, N, F, PAL, UHF,


    Original
    rf12-05-t-00-50-grf28-01-t-00-50-grf20-01-p-00-50-g6994-xx+16993-xx PDF

    sma straight pcb mount

    Abstract: RF Connectors BNC T connectors BNC RECEPTACLE Right Angle for PCB Mount RG-213 uhf crimp SMA Connectors Bulkhead n type adapter female to sma female bulkhead pcb MOUNT of SMA sma n type f type connectors
    Contextual Info: RF CONNECTORS RFC SERIES ADAM TECHNOLOGIES INTRODUCTION: Adam Tech’s RFC series RF connectors are a comprehensive assortment of Radio Frequency signal connectors in standard, miniature, sub-miniature and micro miniature sizes. Included are our BNC, TNC, FME, FMA, SMA, SMB, N, F, PAL, UHF, Mini-UHF,


    Original
    sma straight pcb mountrf connectorsbnc t connectorsbnc receptacle right angle for pcb mount+6rg-213 uhf crimpsma connectors bulkheadn type adapter female to sma female bulkheadpcb mount of smasma n typef type connectors PDF

    RF207

    Abstract: MMCX FEMALE SMT MOUNT 086S rf107 RF205 E224053 d hole sma connector panel MCX Female Panel Chassis Connector MMCX FEMALE PCB MOUNT RF2001
    Contextual Info: Rf CONNECTORs RFc SeRIeS Adam Technologies, Inc. INTRODUCTION: Adam Tech’s RFC series RF connectors are a comprehensive assortment of Radio Frequency signal connectors in standard, miniature, sub-miniature, micro miniature and surface mount styles. Included are our BNC, TNC, FME, FMA, SMA, SMB, N, F, PAL,


    Original
    rf12-05-t-00-50-grf28-01-t-00-50-grf20-01-p-00-50-g6994-xx+116993-xxrf207mmcx female smt mount086srf107rf205e224053d hole sma connector panelmcx female panel chassis connectormmcx female pcb mountrf2001 PDF

    bnc t splitter

    Abstract: RF2-02-T-02-50-G MMCX FEMALE SMT MOUNT rf207 MCX FEMALE PCB MOUNT surface Mount Female bnc connector
    Contextual Info: RF CONNECTORS RFC SERIES Adam Technologies, Inc. INTRODUCTION: Adam Tech’s RFC series RF connectors are a comprehensive assortment of Radio Frequency signal connectors in standard, miniature, sub-miniature, micro miniature and surface mount style. Included are our BNC, TNC, FME, FMA, SMA, SMB, N, F, PAL,


    Original
    rf12-05-t-00-50-grf20-01-p-00-50-grf28-01-t-00-50-g6994-xx+76993-xxbnc t splitterrf2-02-t-02-50-gmmcx female smt mountrf207mcx female pcb mountsurface mount female bnc connector PDF

    2N5109

    Abstract: MRF227 FD700 100 uH Diode C3 uH33 C3 DIODE .47 uH
    Contextual Info: 39 ohm +15 VDC 1 uf + RFC 1000 uh / Freq. in MHz L1 L2 10 ohm C1 Out Q1 13 dBm FD 700 1000 pf C2 C3 Freq. P out C1 C2 C3 L1 L2 Q1 RFC 30 MHz 30 dBm 150 pf 15 pf 39 pf 1.5 uh 1.2 uh 33 uh 2N5109 100 MHz 24 dBm 68 pf 10 pf none .82 uh .47 uh 10 uh 2N5109


    Original
    2n5109mrf227fd700100 uh+4diode c3uh33c3 diode47 uh PDF

    S593T

    Abstract: S593TR MARKING 93 transistor 342 pf Marking SMD 638 smd transistor marking 327
    Contextual Info: S593T/S593TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 5 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. Applications RFC Low noise gain controlled input stages in UHF- and


    Original
    s593t/s593trs593td-74025s593tr+4marking 93transistor 342 pfmarking smd 638smd transistor marking 327 PDF

    S594T

    Abstract: S594TR
    Contextual Info: S594T/S594TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 5 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. RFC Applications Low noise gain controlled input stages in UHF- and


    Original
    s594t/s594trs594td-74025s594tr PDF

    smd transistor 712

    Abstract: S913T S913TR transistor smd marking 431
    Contextual Info: S913T/S913TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 9 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. RFC Applications Low noise gain controlled input stages in UHF- and


    Original
    s913t/s913trs913td-74025smd transistor 712+2s913trtransistor smd marking 431 PDF

    smd transistor marking 327

    Abstract: S595T S595TR 4405 smd Marking SMD 638 "59 R" mosmic
    Contextual Info: S595T/S595TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 5 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. RFC Applications Low noise gain controlled input stages in UHF- and


    Original
    s595t/s595trs595td-74025smd transistor marking 327+4s595tr4405 smdmarking smd 63859 r" mosmic PDF

    S849T

    Abstract: S849TR smd transistor marking 327 marking 70.4
    Contextual Info: S849T/S849TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 12 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. RFC Applications Low noise gain controlled input stages in UHF- and


    Original
    s849t/s849trs849td-74025s849tr+2smd transistor marking 327marking 70.4 PDF

    S887T

    Abstract: S886T S886TR
    Contextual Info: S886T/S886TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 12 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. Applications RFC Low noise gain controlled input stages in UHF- and


    Original
    s886t/s886trs886td-74025s887t+1s886tr PDF

    bnch

    Contextual Info: ADAM TECH RF CONNECTORS RFC SERIES ADAM TECHNOLOGIES INC. INTRODUCTION: Adam Tech RF Series Connectors are high frequency connectors offering broadband performance with low reflection and constant 50 or 75 ohm impedance. They are economical, durable and available in


    OCR Scan
    mil-c-39012bnch PDF

    29 8268 06

    Abstract: PC ladder diagram pc worx fan 7283 D9 female power controller
    Contextual Info: RFC 430/450 ETH-IB Remote Field Controller for Ethernet Networks Data Sheet 6461B 12/2001 Product Description INTERBUS Generation 4 Remote Field Controller with a universal Ethernet gateway with TCP/ IP transport protocol. Features – Automation and control functions according


    Original
    6461brs-422psm-eg-rs422/lwl-g29 8268 06+4pc ladder diagram pc worxfan 7283d9 femalepower controller PDF

    S886T

    Abstract: S886TR J05300 transistor smd 747
    Contextual Info: S886T/S886TR Vishay Telefunken MOSMIC for TV–Tuner Prestage with 12 V Supply Voltage MOSMIC - MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. Applications RFC C block Low noise gain controlled input stages in UHF-and


    Original
    s886t/s886trs886td-7402520-jan-99+3s886trj05300transistor smd 747 PDF

    S849T

    Abstract: S849TR smd marking j5
    Contextual Info: S849T/S849TR Vishay Telefunken MOSMIC for TV–Tuner Prestage with 12 V Supply Voltage MOSMIC - MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. Applications RFC C block Low noise gain controlled input stages in UHF-and


    Original
    s849t/s849trs849td-7402520-jan-99+2s849trsmd marking j5 PDF

    RF3025SB

    Abstract: 30GHz switch RF3025
    Contextual Info: RF3025 RF3025SPDT, High Isolation, Single Control, Absorptive Switch SPDT, HIGH ISOLATION, SINGLE CONTROL, ABSORPTIVE SWITCH Package: QFN, 16-Pin, 3mmx3mm Product Description Features 16 Optimum Technology Matching Applied GaAs HBT 15 14 RFC •  


    Original
    rf3025spdtrf302516-pin10mhz+5ds091125500mhz4000mhzrf3025sb30ghz switch PDF

    Contextual Info: HWS537 GaAs 0.5-6.0 GHz SPDT Switch September 2013 Preliminary Features Top View • Low Insertion Loss: 0.35 dB @ 2.5 GHz • High Isolation: 33 dB @ 2.5 GHz • Single low control voltage: 1.3 to 3.3 V GND RFC GND • No external DC blocking capacitors required


    Original
    hws537uqfn12l PDF

    TRANSISTOR SMD 613

    Abstract: S949T S949TR smd transistor 517 a1 4741 2 marking 99
    Contextual Info: S949T/S949TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 9 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. RFC Applications Low noise gain controlled input stages in UHF- and


    Original
    s949t/s949trs949td-74025transistor smd 613+4s949trsmd transistor 517a1 4741 2marking 99 PDF

    transistor smd 747

    Abstract: S982TR S982T S982 S982T982-GS08
    Contextual Info: S982T/S982TR TELEFUNKEN Semiconductors MOSMIC For TV-Tuner Prestage With 12 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. RFC Applications Low noise gain controlled input stages in UHF- and


    Original
    s982t/s982trs982td-74025transistor smd 747+3s982trs982s982t982-gs08 PDF

    Adam Technologies

    Contextual Info: ADAM TECH RF CONNECTORS RFC SERIES ADAM TECHNOLOGIES INC. INTRODUCTION: Adam Tech RF Series Connectors are high frequency connectors offering broadband performance with low reflection and constant 50 or 75 ohm impedance. They are economical, durable and available in


    OCR Scan
    mil-c-39012adam technologies PDF

    S593T

    Abstract: S593TR
    Contextual Info: S593T/S593TR MOSMIC For TV-Tuner Prestage With 5 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. Applications RFC Low noise gain controlled input stages in UHF- and VHFtuner with 5 V supply voltage.


    Original
    s593t/s593trs593ts593trd-74025+124-apr-96 PDF

    a1 4741 5

    Abstract: a1 4741 2 transistor rf cm 1104 S913T S913TR
    Contextual Info: S913T/S913TR MOSMIC For TV-Tuner Prestage With 9 V Supply Voltage MOSMIC – MOS Monolithic Integrated Circuit Electrostatic sensitive device. Observe precautions for handling. Applications RFC Low noise gain controlled input stages in UHF- and VHFtuner with 9 V supply voltage.


    Original
    s913t/s913trs913ts913trd-74025+424-apr-96a1 4741 5a1 4741 2transistor rf cm 1104 PDF