Part Number
    Please enter a valid full or partial manufacturer part number with a minimum of 3 letters or numbers

    421MM Search Results

    SF Impression Pixel

    421MM Price and Stock

    Select Manufacturer

    Bivar Inc SRS-4-21MM

    Standoffs & Spacers Screw Spacer 21mm PVC Grey
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Mouser Electronics SRS-4-21MM
    • 1 $0.21
    • 10 $0.15
    • 100 $0.12
    • 1000 $0.08
    • 10000 $0.08
    Get Quote
    Newark SRS-4-21MM Bulk 1,000
    • 1 -
    • 10 -
    • 100 -
    • 1000 $0.11
    • 10000 $0.08
    Buy Now
    RS SRS-4-21MM Bulk 1,000
    • 1 -
    • 10 -
    • 100 -
    • 1000 $0.18
    • 10000 $0.16
    Get Quote

    Bivar Inc ELM 4-21MM

    LED Mounting Hardware LED Mount Self Ret 3mm Black 21MM
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    Mouser Electronics ELM 4-21MM
    • 1 -
    • 10 -
    • 100 -
    • 1000 -
    • 10000 $0.09
    Get Quote
    Newark ELM 4-21MM Bulk 1,000
    • 1 -
    • 10 -
    • 100 -
    • 1000 $0.11
    • 10000 $0.10
    Buy Now
    RS ELM 4-21MM Bulk 1,000
    • 1 -
    • 10 -
    • 100 -
    • 1000 $0.13
    • 10000 $0.11
    Get Quote
    TME ELM 4-21MM 1,000
    • 1 -
    • 10 -
    • 100 -
    • 1000 $0.19
    • 10000 $0.13
    Get Quote

    Bimba Manufacturing Company FO-042-1MMT

    CYLINDER, FLAT-I, DBL ACT, SGL ROD, 3/4IN BORE ; STROKE: 2 INCH(S); PIVOT MOUN
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    RS FO-042-1MMT Bulk 5 Weeks 1
    • 1 $123.10
    • 10 $113.25
    • 100 $113.25
    • 1000 $113.25
    • 10000 $113.25
    Get Quote

    Bimba Manufacturing Company FO-042-1MMTS3T1

    CYLINDER, FLAT-I, DBL ACT, SGL ROD, 3/4IN ; STROKE: 2 INCH(S); PIVOT MOUNT [1]
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    RS FO-042-1MMTS3T1 Bulk 5 Weeks 1
    • 1 $133.35
    • 10 $122.68
    • 100 $122.68
    • 1000 $122.68
    • 10000 $122.68
    Get Quote

    Eaton Corporation XLR-51R3187-R

    Supercapacitors / Ultracapacitors 188F 51.3V EDLC CAP Module
    Distributors Part Package Stock Lead Time Min Order Qty Price Buy
    TTI XLR-51R3187-R Bulk 1
    • 1 -
    • 10 -
    • 100 -
    • 1000 -
    • 10000 -
    Buy Now

    421MM Datasheets Context Search

    Catalog Datasheet Type Document Tags PDF

    Contextual Info: ISOMETRIC VIEW 13mm 0.5in 332mm 13.06in TOP VIEW 421mm 16.59in 88mm 3.47in 95mm 3.75in REAR VIEW L.S VIEW FRONT VIEW HPLD15 PART NUMBERS PAINTED TEXTURED BLACK NOTES HPLD Plinth side panels ordered separately to close ends See Hammond Website for Additional Accessories.


    Original
    332mm421mmhpld15 PDF

    Contextual Info: ISOMETRIC VIEW 13mm 0.5in 332mm 13.06in TOP VIEW 421mm 16.59in 188mm 7.41in 195mm 7.69in REAR VIEW L.S VIEW FRONT VIEW HPLD25 PART NUMBERS PAINTED TEXTURED BLACK NOTES HPLD Plinth side panels ordered separately to close ends See Hammond Website for Additional Accessories.


    Original
    332mm421mm188mm195mm+1hpld25 PDF

    OBIC 2000-500.0

    Contextual Info: Oil Impregnated Film Capacitor OBIC 2000-500.0 145375400 230mm M 16 80mm 145mm Impregnated with Environmentally Friendy SAS60 Synthetic Oil 95 145 400mm 150mm 375mm 421mm 455mm Parameter Capacitance Tolerance Rated voltage RMS Current Peak Repetition Cycle


    Original
    230mm145mmsas60400mm+5150mm375mm421mm455mmobic 2000-500.0 PDF

    lq121s1dg11

    Abstract: CXA-0247 CXA-0217 sharp lcd 128 240 DF9-41S-1V DF9A-41S-1V DF9B-41S-1V connector DF9 31 pin taiwan lcd t41s
    Contextual Info: LQ121S1DG11 TFT-LCD Module Model Number: LQ121S1DG11 Specifications Spec No.: LD-10Z13A Dated: June 10, 2002 PREPARED BY : DATE SPEC No. LD-10Z13A FILE No. ISSUE : Dec.22 1998 APPROVED BY : DATE PAGE : 16 pages TFT Liquid Crystal Display Group SHARP CORPORATION


    Original
    lq121s1dg11ld-10z13ald-10z13-1cxa-0247+7cxa-0217sharp lcd 128 240df9-41s-1vdf9a-41s-1vdf9b-41s-1vconnector df9 31 pin taiwan lcdt41s PDF

    10km of FM TRANSMITTER CIRCUIT DIAGRAM

    Abstract: loop antennas vhf RF amplifier antenna 125khz vctcxo 10Mhz 125kHz loop antenna LMR1-169-5-12k5 yagi vhf quarterwave dipole antenna design vhf receiver data sheet 220-6 diode
    Contextual Info: W E N Radiometrix Hartcran House, 231 Kenton Lane, Harrow, HA3 8RP, England Issue 1, 16 October 2007 Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233 ENT1 12.5 12.5kHz kHz Channel Channel VHF High Power TX The ENT1 transmitter modules offer a 100mW RF output VHF data link in


    Original
    100mw10km of fm transmitter circuit diagramloop antennas vhfrf amplifier antenna 125khz+7vctcxo 10mhz125khz loop antennalmr1-169-5-12k5yagi vhfquarterwave dipole antenna designvhf receiverdata sheet 220-6 diode PDF

    6063-T6

    Abstract: BP Solar BP Solar sx 310 SX310 solar 1.5 Watt photovoltaic module BP Solar SX310
    Contextual Info: SX 310 10 Watt Photovoltaic Module High-efficiency photovoltaic module using silicon nitride multicrystalline silicon cells. Performance Rated power Pmax Power tolerance Nominal voltage Limited Warranty1 10W ± 10% 12V 12 years Configuration M J Multimount frame with lo-pro J-Box and output cable


    Original
    sx3106063-t6bp solarbp solar sx 310+3solar 1.5 wattphotovoltaic modulebp solar sx310 PDF

    Contextual Info: PHYSICAL LAYER PRODUCTS PRODUCT DATACOM VSC7226 VSC7226 Quad 3.125Gb/s Backplane Transceiver S P E C I F I C AT I O N S : 4REFCLK: 24.5 MHz - 312.5 MHz 4Tx/Rx REFCLK Offset: 200 ppm 4Serial Input Differential Terminations Adjustable Between 100Ω and 150Ω


    Original
    vsc7226125gb/s1875gb/s25gb/s+3vsc7640vsc732010gb/s PDF

    china model inverter circuit diagram

    Abstract: 50FLZX D639 D640 LQ197V3DZ89 S12B inverter DC AC Back Light INVERTER MODULE 50FLZX-RSM1-A-GB-TBJST 50-fl
    Contextual Info: PRODUCT SPECIFICATIONS AVC Liquid Crystal Displays Group LQ197V3DZ89 TFT-LCD Module Spec. Issue Date: Mar. 01, 2005 No: LD-17221 RECORDS OF REVISION MODEL No : LQ197V3DZ89 SPEC No : LD-17221 DATE 2005.03.01 Rev No. PAGE SUMMARY NOTE - - 1st Issue LD−17221−1


    Original
    lq197v3dz89ld-17221ld-17221-1china model inverter circuit diagram+850flzxd639d640s12binverter dc acback light inverter module50flzx-rsm1-a-gb-tbjst50-fl PDF

    Contextual Info: Hartcran House, 231 Kenton Lane, Harrow, Middlesex, HA3 8RP, England Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233, www.radiometrix.com Issue 3, 27 July 2012 BiM1H 12345677894A6BC43D4EFF 4 76B 7 The BiM1H transceiver modules offer a 500mW RF output VHF data link in


    Original
    12345677894a6bc43d4eff500mwbim1h-1694125mhz+2120mhz180mhz PDF

    CXA-0247

    Abstract: sharp lq121s1dg11 CXA-0217 cxa inverter tdk tdk cxa lq121s1dg1 DF9MA-41P-1V
    Contextual Info: ENH121S1-250/350 Panelview Enhancing the Vision ENH121S1-250/350 Color TFT-LCD Module Features GENERAL DESCRIPTION The TFT-LCD panel used for this module is a lowreflection and higher-color-saturation type. Therefore, this module is also suitable for the multimedia use. Viewing


    Original
    enh121s1-250/350lq121s1dg11im/110800x3x600+7cxa-0247sharp lq121s1dg11cxa-0217cxa inverter tdktdk cxalq121s1dg1df9ma-41p-1v PDF

    Contextual Info: Canada & International Hammond Manufacturing Company Limited 394 Edinburgh Rd North Guelph, ON N1H 1E5 Tel: 519 822 - 2960 Fax: (519) 822 - 0715 Eml: sales@hammondmfg.com Les Fabrications Hammond (Quebec) Inc. 4240 Rue Seré St. Laurent, Quebec H4T 1A6 Tel: (514) 343-9010


    Original
    PDF

    Contextual Info: Hartcran House, 231 Kenton Lane, Harrow, Middlesex, HA3 8RP, England Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233, www.radiometrix.com ENT1/ENR1 123456789ABCCDE8F6 8 8 8 Issue 1, 27 July 2012 The ENT1 and ENR1 form a miniature VHF radio transmitter/receiver pair designed for PCB


    Original
    123456789abccde8f644375mhz40625mhz PDF

    10km of FM TRANSMITTER CIRCUIT DIAGRAM

    Abstract: 169MHz antenna loop antennas vhf Antennas vhf HX1-144.800-3 VHF transmitter circuit 500m-1km 10-15km vhf fm transmitter radiometrix hx1
    Contextual Info: W E N Radiometrix Hartcran House, 231 Kenton Lane, Harrow, HA3 8RP, England 28 August 2007 Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233 HX1 (300mW) VHF Narrow Band FM 300mW Transmitter The special HX1 transmitter modules offer a 300mW RF output VHF data


    Original
    300mwhx1-169125-3-5v169mhz+1010km of fm transmitter circuit diagram169mhz antennaloop antennas vhfantennas vhfhx1-144.800-3vhf transmitter circuit500m-1km10-15kmvhf fm transmitterradiometrix hx1 PDF

    Contextual Info: W E N Radiometrix Hartcran House, 231 Kenton Lane, Harrow, HA3 8RP, England Issue 1, 02 March 2009 Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233 ENX1 VH F 1 2 .5 k H z c h an n el N B FM TRA N S CEI VER The ENX1 transceiver module offers a 100mW RF output VHF data link in a


    Original
    100mwenx1-16940625mhz44375mhz+2120mhz180mhz PDF

    10km of FM TRANSMITTER CIRCUIT DIAGRAM

    Abstract: 169MHz antenna HX1-169 VHF transmitter circuit VHF transmitter radiometrix 845 motherboard circuit em 4033 10-15km 845 MOTHERBOARD CIRCUIT diagram Antenna design magnetic loop antennas
    Contextual Info: W E N Radiometrix Hartcran House, 231 Kenton Lane, Harrow, HA3 8RP, England 28 August 2007 Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233 HX1 (300mW) VHF Narrow Band FM 300mW Transmitter The special HX1 transmitter modules offer a 300mW RF output VHF data


    Original
    300mwhx1-169125-3-5v169mhz+910km of fm transmitter circuit diagram169mhz antennavhf transmitter circuitvhf transmitter radiometrix845 motherboard circuitem 403310-15km845 motherboard circuit diagramantenna design magnetic loop antennas PDF

    10km of FM TRANSMITTER CIRCUIT DIAGRAM

    Abstract: 21.4mhz filter 169MHz antenna quarterwave dipole antenna design RF amplifier antenna 125khz EN300-220 PCB Antenna 125KHz loop antennas vhf vhf antenna pcb design ENX1
    Contextual Info: W E N Radiometrix Hartcran House, 231 Kenton Lane, Harrow, HA3 8RP, England Issue 1, 02 March 2009 Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233 ENX1 VHF 12.5kHz channel NBFM TRANSCEIVER The ENX1 transceiver module offers a 100mW RF output VHF data link in a


    Original
    100mwenx1-16940625mhz44375mhz+11120mhz10km of fm transmitter circuit diagram21.4mhz filter169mhz antennaquarterwave dipole antenna designrf amplifier antenna 125khzen300-220pcb antenna 125khzloop antennas vhfvhf antenna pcb designenx1 PDF

    VHF Radio transmitter

    Abstract: vhf fm receiver EN300-220 10km of FM TRANSMITTER CIRCUIT DIAGRAM
    Contextual Info: W E N Radiometrix Hartcran House, 231 Kenton Lane, Harrow, HA3 8RP, England Issue 1, 17 October 2008 Tel: +44 0 20 8909 9595, Fax: +44 (0) 20 8909 2233 ENT1/ENR1 12.5kHz Channel VHF TX / RX The ENT1 and ENR1 form a miniature VHF radio transmitter/receiver pair designed for


    Original
    44375mhz40625mhzvhf radio transmittervhf fm receiver+2en300-22010km of fm transmitter circuit diagram PDF

    RFC-894

    Abstract: IMSB014 IMS B300
    Contextual Info: IMS B300 TCPlink Development System Ethernet transceiver OS-Links AUI cable Ethernet cable ST20450 Development Board IMS B300 TCPLink box Diagnostic terminal Differential subsystem cables e.g. IMS CA15 Single-ended subsystem cables FEATURES Compact desktop design, suitable for office or


    Original
    st20450rfc-894imsb014ims b300 PDF

    RFC894

    Abstract: ibm pc FRONT PANEL connector CIRCUIT transistor b014 RFC-1122 pc monitor female connector dimensions PC MOTHERBOARD SERVICE MANUAL RFC-826 RFC-894 VME COnnector ST20450
    Contextual Info: IMS B300 TCPlink Development System Ethernet transceiver OS-Links AUI cable Ethernet cable ST20450 Development Board IMS B300 TCPLink box Diagnostic terminal Differential subsystem cables e.g. IMS CA15 Single-ended subsystem cables FEATURES Compact desktop design, suitable for office or


    Original
    st20450rfc894ibm pc front panel connector circuittransistor b014+6rfc-1122pc monitor female connector dimensionspc motherboard service manualrfc-826rfc-894vme connector PDF

    48v 2500w

    Abstract: AC264V 10a50a
    Contextual Info: AC/DC 高频开关电源模块系列(恒压/ 单相输入/ 单路输出/ 小功率 ) HN1S05 I 型 26V/4A 高频开关电源 性能指标: ? ? ? ? ? ? ? ? ? ? ? HN1S05 I 型 26V/4A 高频开关电源 ? ? 交流电压范围:176Vac~264Vac


    Original
    hn1s05176vac264vac45hz55hz26vdc27vdc+7150mv4000vachnj1s105v/15a48v 2500wac264v10a50a PDF